Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-July-22 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday July 22, 7:50 AM - 9:00 AM UTC

What happened:

iOS devices were not available in the US-West Datacenter

Why it happened:

We introduced a new health check, adding more load to the process of re-signing applications. When we deployed a new release the added load brought down the machines hosting the iOS devices. 

How we fixed it:

The host machines were restarted and the re-signer services were re-deployed.

What we are doing to prevent it from happening again:

We are improving the application re-signing process to reduce the load on the host machines and added more monitoring to spot extra loads on the re-signers services earlier on.

Posted Jul 27, 2021 - 16:27 UTC

Resolved
iOS Real Device availability is restored to normal operational levels. This incident is resolved.
Posted Jul 22, 2021 - 09:09 UTC
Identified
The issue has been identified and a fix implemented. iOS device availability is recovering.
Posted Jul 22, 2021 - 08:46 UTC
Update
We are continuing to investigate this issue.
Posted Jul 22, 2021 - 08:16 UTC
Investigating
iOS Real Devices in our US-West Datacenter are currently unavailable. We are taking remedial action.
Posted Jul 22, 2021 - 08:16 UTC
This incident affected: Automated Real Device Testing (US-West) and Live Real Device Testing (US-West).