2018-December-21 Service Incident
Incident Report for Sauce Labs Inc
Resolved
Emergency maintenance is concluded. Real Device Cloud services are operational again. RDC self-service customer invoice downloads are disabled for the time being.
Posted about 1 month ago. Dec 21, 2018 - 15:52 PST
Update
We are continuing to work on this emergency maintenance.
Posted about 1 month ago. Dec 21, 2018 - 14:18 PST
Identified
Our Real Device Cloud user interface is down for emergency maintenance. We are working on bringing it back up as soon as possible.
Posted about 1 month ago. Dec 21, 2018 - 13:46 PST
This incident affected: Automated RDC Testing (Automated RDC Testing, EU Data Center, Automated RDC Testing, US Data Center), Web Interface (Real Device Cloud UI), and Manual Testing (Manual RDC Testing).