2017-March-27 Service Incident
Incident Report for Sauce Labs Inc

Date of Incident: March 27, 2017
Time of Incident: 11:00am - 12:45pm PDT, 1:20pm - 1:40pm PDT

What Happened:
Wait times for VMs exceeded 30 seconds, which can cause some tests to error or not start.

Why it Happened:
We have determined that the service responsible for creating and halting VMs was recovering slower than usual after a restart, which happens when Sauce Labs deploys changes.

What we did to fix it:
We increased the overall amount of CPU and RAM we allocate to the service responsible for creating and halting VMs. We also significantly refactored how that service reads and writes to its data store, providing a significant boost in speed.

We thoroughly tested these changes under production conditions and we are confident we have addressed the issue.

What we are doing to prevent this from happening again:
We added a considerable amount of instrumentation and analytics to that service so we can quickly and proactively diagnose similar issues in the future.

Posted 8 months ago. Mar 30, 2017 - 19:52 PDT

Resolved
Wait times have returned to normal levels. All services are fully operational.
Posted 8 months ago. Mar 27, 2017 - 14:57 PDT
Monitoring
Wait times have improved greatly and we’re monitoring performance closely.
Posted 8 months ago. Mar 27, 2017 - 13:02 PDT
Update
Wait times are still high for tests run on our Mac and PC cloud. We’re continuing to work on a solution.
Posted 8 months ago. Mar 27, 2017 - 12:20 PDT
Investigating
Our Mac and PC clouds are experiencing high wait times. We’re taking remedial action.
Posted 8 months ago. Mar 27, 2017 - 11:28 PDT
This incident affected: Sauce Automated.