2018-May 9 Service Incident
Incident Report for Sauce Labs Inc
Resolved
The corrected DNS entries appear to have fully propagated. All customers appear to be accessing our services normally. If problems continue, please contact us at help@saucelabs.com.
Posted 5 months ago. May 11, 2018 - 11:09 PDT
Update
The corrected DNS entries continue to propagate. Usage of our service has almost returned to normal levels, which suggests many customers are running tests normally; however, there are still reports of saucelabs.com and ondemand.saucelabs.com not resolving to the correct IP. Known workarounds can be found at: https://support.saucelabs.com/hc/en-us/articles/360004062474-Using-Sauce-Labs-while-new-DNS-entries-are-propagating-following-May-8-2018-incident
Posted 5 months ago. May 10, 2018 - 12:53 PDT
Update
We are continuing to monitor for any further issues.
Posted 6 months ago. May 09, 2018 - 18:07 PDT
Monitoring
The updated DNS entries for saucelabs.com and ondemand.saucelabs.com are still in the propagation process. Some users will be unable to run automated tests, reach our UI, start Sauce Connect, or use the REST API. Alternate means to use our service can be found at https://support.saucelabs.com/hc/en-us/articles/360004062474-Using-Sauce-Labs-while-new-DNS-entries-are-propagating-following-May-8-2018-incident-
Posted 6 months ago. May 09, 2018 - 18:06 PDT
This incident affected: Sauce Connect (Sauce Connect VM), Manual Testing (Manual VM Testing), REST API (REST API VMs), Web Interface (Sauce UI, Analytics, saucelabs.com, Documentation Wiki), Automated VM Testing (Automated PC Testing), and Automated RDC Testing (Automated RDC Testing, US Data Center).