2017-November-6 Service Incident
Incident Report for Sauce Labs Inc
Resolved
All services are fully operational.
Posted 14 days ago. Nov 06, 2017 - 13:41 PST
Monitoring
Saucelabs website is back up and running again - temporary redirect has been removed.
Posted 14 days ago. Nov 06, 2017 - 13:37 PST
Identified
Users are temporarily re-directed to our login page while our upstream website host experiences connectivity issues.
Posted 14 days ago. Nov 06, 2017 - 13:24 PST
Investigating
The Sauce Labs website is not responding, but the Sauce Web Application can still be accessed by going to https://saucelabs.com/beta/login
Posted 14 days ago. Nov 06, 2017 - 13:00 PST
This incident affected: saucelabs.com.