Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-May-25 Service Incident (3)
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday May 25th 2022, 15:16 - 16:50 UTC

What happened:

Automated testing in our US-East-1 data center was not working as expected. Customers were either experiencing tests not starting or commands not executing correctly for active sessions.

Why it happened:

During routine maintenance, application configuration for a key service was improperly altered causing a deployment to break. 

How we fixed it:

We redeployed the service with the proper configuration.

What we are doing to prevent it from happening again:

We are making certain sections of the application configuration more explicit and documented to prevent this from happening in the future.

Posted Jun 14, 2022 - 10:22 UTC

Resolved
After taking remedial action we are seeing Headless tests starting as normal. All services are fully operational.
Posted May 25, 2022 - 16:51 UTC
Update
Headless testing on our us-east-1 data center continues to get errors. Tests might start but will error out with 503 shortly after. We continue to investigate.
Posted May 25, 2022 - 16:00 UTC
Investigating
Headless testing on our us-east-1 data center currently errors out with 503 error message. We are investigating.
Posted May 25, 2022 - 15:22 UTC