Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2021-July-23 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

July 23, 2021 0730 - July 24, 2021 0730 UTC

What happened:

Wait times rose significantly for Mac Desktop and iOS Simulator tests on our US-West Mac cloud.

Why it happened:

There was a higher than normal amount of demand for our Mac/iOS Simulator offering which put a significant load on our systems and prevented them from servicing customer jobs in a timely manner.

How we fixed it:

Wait times subsided once demand returned to normal levels.

What we are doing to prevent it from happening again:

We have made service changes that have improved the efficiency of our systems and we will continue to look for ways to improve the reliability and efficiency of our platform. We are actively working to make more capacity available to reduce the impact of peaks of load on our systems going forward.

Posted Jul 31, 2021 - 17:28 UTC

Resolved
This incident has been resolved.
Posted Jul 23, 2021 - 15:21 UTC
Monitoring
We are still monitoring and wait times continue to improve.
Posted Jul 23, 2021 - 12:08 UTC
Identified
We have taken remedial action and wait times are beginning to return to normal.
Posted Jul 23, 2021 - 10:14 UTC
Investigating
We are seeing elevated wait times affecting MacOS and iOS Simulator testing in our US-West-1 Datacenter. We are investigating.
Posted Jul 23, 2021 - 09:05 UTC
This incident affected: Automated Browser Testing (US-West), Automated Virtual Mobile Device Testing (US-West), Live Browser Testing (US-West), and Live Virtual Mobile Device Testing (US-West).