Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-May-25 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday May 25th 2022, 03:00 - 8:11 UTC

What happened:

Sauce Labs Live and Automated Real Device tests were not loading in the Sauce Labs UI in our US-West-1 Data Center.

Why it happened:

An service provider connection input stream exception was raised, causing failure to do IO operations in our storage service which holds test page assets (logs, video, etc.) 

How we fixed it:

We reset the affected services to initially solve the issue, storage service logic was reviewed and we did enhancements and planning internal monitoring measures to detect any future issues faster.

What we are doing to prevent it from happening again:

We are investigating how we can better ensure that we are correctly tracking connection health of services such as this.

Posted Jun 06, 2022 - 16:06 UTC

Resolved
After taking remedial action all test results are loading on our US-West-1 data center.
Posted May 25, 2022 - 08:33 UTC
Investigating
Test results are not loading for Real Device tests in our US-West-1 data center. We are investigating.
Posted May 25, 2022 - 07:43 UTC
This incident affected: Sauce Labs Dashboard (US-West).