2017-August-30 Service Incident
Incident Report for Sauce Labs Inc

Date: August 30, 2017
Time: 12:37am - 3:37am

What Happened:
A subset of REST API endpoints (those that cache results) were returning incorrect information. As a result, the manual test UI and CI plugins were unable to list all available platform options.

Why It Happened:
One of the servers that replies to REST requests ran out of disk space. The disk space monitor did not alert because it was configured incorrectly.

What We Did To Fix It:
We redirected REST requests to another server and cleared disk space on the impacted server.

What We Are Doing To Prevent This From Happening Again:
We have fixed the disk space monitor.

Posted 20 days ago. Sep 05, 2017 - 14:19 PDT

Resolved
All services are fully operational.
Posted 27 days ago. Aug 30, 2017 - 03:41 PDT
Identified
We have identified an issue with the platforms REST API, affecting Manual testing and CI server plugins.
Posted 27 days ago. Aug 30, 2017 - 03:25 PDT
Investigating
Manual testing is currently unavailable. We are investigating.
Posted 27 days ago. Aug 30, 2017 - 03:18 PDT
This incident affected: Sauce Manual, REST API, and saucelabs.com.