Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-Feb-19 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Friday, February 12, 2021, 11:30 PST - Monday, February 15, 2021 14:10 PST (first occurrence)

Thursday, February 18, 2021, 21:00 PST - Friday, February 19, 2021 13:30 PST (second occurrence)

What happened:

IPSec VPN tunnels in the US-West region timed out. 

Why it happened:

A monitoring change that was introduced led to high CPU usage and resource exhaustion on our IPSec concentrator cluster in the US-West-1 data center.

How we fixed it:

We restarted a process on the IPSec concentrator cluster in the US-West-1 data center and also rolled back the monitoring change that triggered the event.

What are we doing to prevent it from happening again:

We are re-evaluating our monitoring implementation for this product and working with the vendor to address software issues.

Posted Mar 01, 2021 - 22:37 UTC

Resolved
IPSec/VPN Tunnels are now functional, the issue has been identified and resolved.
Posted Feb 19, 2021 - 22:24 UTC
Investigating
IPSec/VPN Tunnels in our US-West-1 data center are currently experiencing partial disruption in service. We are taking remedial action.
Posted Feb 19, 2021 - 20:55 UTC
This incident affected: IPSec VPN (US-West).