Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
All Systems Operational
Automated Browser Testing Operational
90 days ago
99.95 % uptime
Today
US-West Operational
90 days ago
99.9 % uptime
Today
EU-Central Operational
90 days ago
100.0 % uptime
Today
Automated Virtual Mobile Device Testing Operational
90 days ago
99.97 % uptime
Today
US-West Operational
90 days ago
99.95 % uptime
Today
EU-Central Operational
90 days ago
100.0 % uptime
Today
Automated Real Device Testing Operational
90 days ago
99.73 % uptime
Today
US-West Operational
90 days ago
99.52 % uptime
Today
EU-Central Operational
90 days ago
99.66 % uptime
Today
US-East Operational
90 days ago
100.0 % uptime
Today
Native Framework Mobile App Testing Operational
90 days ago
99.61 % uptime
Today
US-West Operational
90 days ago
99.57 % uptime
Today
EU-Central Operational
90 days ago
99.66 % uptime
Today
Sauce Orchestrate Operational
90 days ago
100.0 % uptime
Today
US-West Operational
90 days ago
100.0 % uptime
Today
EU-Central Operational
90 days ago
100.0 % uptime
Today
Live Browser Testing Operational
90 days ago
99.97 % uptime
Today
US-West Operational
90 days ago
99.95 % uptime
Today
EU-Central Operational
90 days ago
100.0 % uptime
Today
Live Virtual Mobile Device Testing Operational
90 days ago
100.0 % uptime
Today
US-West Operational
90 days ago
100.0 % uptime
Today
EU-Central Operational
90 days ago
100.0 % uptime
Today
Live Real Device Testing Operational
90 days ago
99.73 % uptime
Today
US-West Operational
90 days ago
99.54 % uptime
Today
EU-Central Operational
90 days ago
99.66 % uptime
Today
US-East Operational
90 days ago
100.0 % uptime
Today
API Testing Operational
90 days ago
100.0 % uptime
Today
US-West Operational
90 days ago
100.0 % uptime
Today
EU-Central Operational
90 days ago
100.0 % uptime
Today
Visual Testing Operational
90 days ago
100.0 % uptime
Today
Visual Testing Hub Operational
90 days ago
100.0 % uptime
Today
Visual Testing Infrastructure Operational
90 days ago
100.0 % uptime
Today
Visual Testing REST API Operational
90 days ago
100.0 % uptime
Today
Legacy Visual Testing (Screener) UI Operational
90 days ago
100.0 % uptime
Today
Mobile Beta Testing (TestFairy) Operational
90 days ago
100.0 % uptime
Today
TestFairy Platform Operational
90 days ago
100.0 % uptime
Today
TestFairy UI Operational
90 days ago
100.0 % uptime
Today
Sauce Connect Operational
90 days ago
100.0 % uptime
Today
US-West Operational
90 days ago
100.0 % uptime
Today
EU-Central Operational
90 days ago
100.0 % uptime
Today
IPSec VPN Operational
90 days ago
100.0 % uptime
Today
US-West Operational
90 days ago
100.0 % uptime
Today
EU-Central Operational
90 days ago
100.0 % uptime
Today
Sauce Labs REST API Operational
90 days ago
100.0 % uptime
Today
US-West Operational
90 days ago
100.0 % uptime
Today
EU-Central Operational
90 days ago
100.0 % uptime
Today
Sauce Labs Dashboard Operational
90 days ago
99.98 % uptime
Today
US-West Operational
90 days ago
99.99 % uptime
Today
EU-Central Operational
90 days ago
99.97 % uptime
Today
Insights Operational
90 days ago
100.0 % uptime
Today
US-West Operational
90 days ago
100.0 % uptime
Today
EU-Central Operational
90 days ago
100.0 % uptime
Today
Billing Operational
90 days ago
100.0 % uptime
Today
US-West Operational
90 days ago
100.0 % uptime
Today
EU-Central Operational
90 days ago
100.0 % uptime
Today
Other Operational
90 days ago
100.0 % uptime
Today
saucelabs.com Operational
90 days ago
100.0 % uptime
Today
Sauce Labs Documentation Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Scheduled Maintenance
Sauce Labs Planned Maintenance Mar 20, 2024 06:30-08:30 UTC
Sauce Labs will have a two hour additional maintenance window on March 20th, starting at 06:30 UTC and ending at 08:30 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our EU and US-East data centers. These maintenance actions may cause portions of the service (including running automated and manual tests) relating to iOS real devices to be unavailable for up to two hours.
Posted on Mar 18, 2024 - 10:42 UTC
Sauce Labs Planned Maintenance Mar 21, 2024 06:30-08:30 UTC
Sauce Labs will have a two hour additional maintenance window on March 21st, starting at 06:30 UTC and ending at 08:30 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US-West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) relating to iOS real devices to be unavailable for up to two hours.
Posted on Mar 18, 2024 - 10:43 UTC
Sauce Labs Planned Maintenance Mar 23, 2024 18:00-20:00 UTC
Sauce Labs will have a two hour previously scheduled maintenance window on March 23rd, starting at 18:00 UTC and ending at 20:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our EU data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to two hours.
Posted on Feb 01, 2024 - 23:20 UTC
Sauce Labs Planned Maintenance Apr 20, 2024 17:00-19:00 UTC
Sauce Labs will have a two hour previously scheduled maintenance window on April 20th, starting at 17:00 UTC and ending at 19:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our EU and US data centers. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to two hours.
Posted on Mar 12, 2024 - 20:54 UTC
US-West-1 Windows and Linux VM Wait Times ?
Fetching
US-West-1 OSX and iOS Wait Times ?
Fetching
US-West-1 Android Emulator Wait Times ?
Fetching
US-West-1 Concurrency REST API Response Times ?
Fetching
EU-Central-1 Windows and Linux Wait Times ?
Fetching
EU-Central-1 OSX and iOS Wait Times ?
Fetching
EU-Central-1 Android Emulator Wait Times ?
Fetching
EU-Central-1 Concurrency REST API Response Times ?
Fetching
Past Incidents
Mar 19, 2024

No incidents reported today.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.

Mar 14, 2024
Resolved - Between 4:00-6:30 AM UTC, we were experiencing errors retrieving test artifacts for test results in our US-West-1 datacenter. This has now been resolved and all test results are available, no data loss was incurred.
Mar 14, 04:00 UTC
Mar 13, 2024
Resolved - After taking remedial action, Samsung Real devices are available in all our data centers. This incident is now resolved.
Mar 13, 16:36 UTC
Identified - The issue has been identified and a fix is being implemented.
Mar 13, 14:31 UTC
Update - We continue to experience reduced availability of Samsung Real devices in our Public pool in the US-West-1 and EU-Central-1 data centers. We continue to investigate.
Mar 13, 10:06 UTC
Update - We continue to experience reduced availability of Samsung Real devices in our Public pool in the US-West-1 and EU-Central-1 data centers. Investigation is underway.
Mar 12, 22:40 UTC
Update - We are experiencing reduced availability of Samsung Real devices in our US-West-1 and EU-Central-1 data centers. We continue to investigate.
Mar 12, 16:55 UTC
Investigating - We are experiencing reduced availability of Samsung Real devices in the US-West-1 data center. We are investigating.
Mar 12, 14:12 UTC
Mar 12, 2024
Mar 11, 2024
Resolved - After taking remedial action, we are seeing error rates return to normal levels. This incident is now resolved.
Mar 11, 13:38 UTC
Update - We are seeing elevated error rates in Desktop tests in the US-West-1 datacenter. We continue to investigate.
Mar 11, 11:17 UTC
Investigating - We are currently seeing elevated error rates in Desktop tests in the US-West-1 datacenter. We are investigating.
Mar 11, 10:14 UTC
Mar 10, 2024

No incidents reported.

Mar 9, 2024
Completed - The scheduled maintenance has been completed.
Mar 9, 20:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 9, 18:00 UTC
Scheduled - Sauce Labs will have a two hour previously scheduled maintenance window on March 9th, starting at 18:00 UTC and ending at 20:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to two hours.
Feb 1, 23:17 UTC
Mar 8, 2024

No incidents reported.

Mar 7, 2024

No incidents reported.

Mar 6, 2024
Resolved - This incident has been resolved.
Mar 6, 19:37 UTC
Investigating - We are currently experiencing intermittent issues loading real device test reports on the dashboard in our US West Data Center. We are investigating.
Mar 6, 19:03 UTC
Resolved - This incident has been resolved.
Mar 6, 09:52 UTC
Monitoring - After taking remedial action, the redirect is working as expected. We are currently monitoring.
Mar 5, 21:57 UTC
Investigating - We've identified redirect issues for Mobile Beta login on our Dashboard in both US-West-1 and EU-Central-1 Datacenters. Investigation is underway.
Mar 5, 21:12 UTC
Mar 5, 2024