2018-May-10 Service Incident
Incident Report for Sauce Labs Inc
Resolved
This incident has been resolved.
Posted 3 months ago. May 10, 2018 - 02:11 PDT
Monitoring
Wait times are returning to normal levels and we are monitoring for further issues.
Posted 3 months ago. May 10, 2018 - 01:51 PDT
Investigating
Wait times for Automated and Manual tests are elevated and we are investigating.
Posted 3 months ago. May 10, 2018 - 01:23 PDT
This incident affected: Automated VM Testing (Automated PC Testing) and Manual Testing (Manual VM Testing).