2017-August-21 Service Incident
Incident Report for Sauce Labs Inc
Resolved
Our website, www.saucelabs.com, is working normally again. All services are fully operational.
Posted 3 months ago. Aug 21, 2017 - 17:38 PDT
Investigating
Our website, www.saucelabs.com, is having intermittent failures. Our Content Management Service provider is investigating the cause. Our web application and testing services are unaffected.
Posted 3 months ago. Aug 21, 2017 - 17:10 PDT