Sauce Labs Maintenance Window
We are aware of an ongoing issue preventing logins to App Distribution when using Single Sign-On (SSO). We are actively investigating..

2026-February-23 Service Incident

Incident Report for Sauce Labs

Resolved

We have identified the root cause and deployed a fix for this issue. All services are fully operational.
Posted Feb 23, 2026 - 22:31 UTC

Update

We have identified the root cause and are working on implementing a fix. We are continuing to investigate.
Posted Feb 23, 2026 - 19:40 UTC

Investigating

We are seeing an increase in automated tests using Sauce Connect failing with “Misconfigured -- No active tunnel found for provided identifier” errors in the US-West-1 data center. We are actively investigating.
Posted Feb 23, 2026 - 17:22 UTC
This incident affected: Automated Browser Testing (US-West), Automated Virtual Mobile Device Testing (US-West), Automated Real Device Testing (US-West), Sauce Connect (US-West), and US-West.