Sauce Labs Maintenance Windows for Sauce Labs
We are aware of and working to resolve intermittent WiFi connectivity and slowness issues affecting Android Real Devices in our US-West-1 data center. Please contact our Support team should you wish to report any such issues.

2021-September-02 (2) Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

September 1st 2021, 22:22 - September 3rd 2021 03:00 UTC

What happened:

Android Emulator tests that specified the Extended Debugging capability were non-operational and resulted in Internal Server Errors being reported.

Why it happened:

A deployment that included an error prevented these tests from starting.

How we fixed it:

The error was patched, and the update was deployed to our EU-Central-1 and US-West-1 data centers.

What we are doing to prevent it from happening again:

Test suites are being updated to ensure that similar issues will be caught before production deploys.

Posted Sep 09, 2021 - 15:30 UTC

Resolved
Android Emulator tests are working across US and EU Data Centers. All services are now fully operational
Posted Sep 03, 2021 - 03:18 UTC
Update
Android Emulator tests on our EU Data Center are fully operational. We are currently working restoring the same on our US Data Center
Posted Sep 03, 2021 - 02:14 UTC
Identified
We have identified the cause and taking remedial action.
Posted Sep 02, 2021 - 23:39 UTC
Investigating
We are experiencing increased rate of failures running automated tests on Android Emulators. We are investigating.
Posted Sep 02, 2021 - 22:12 UTC
This incident affected: Automated Virtual Mobile Device Testing (US-West, EU-Central).