Sauce Labs Maintenance Windows for Sauce Labs
We are aware of and working to resolve intermittent WiFi connectivity and slowness issues affecting Android Real Devices in our US-West-1 data center. During a maintenance window on September 25, we made changes to our wireless infrastructure which has greatly improved the situation, but we are still monitoring and working on further improvements. Please contact our Support team should you wish to report any such issues.

2022-Jan-11 Service Incident
Incident Report for Sauce Labs
Resolved
The third party’s outage has been marked as resolved. All services are fully operational.
Posted Jan 11, 2022 - 21:19 UTC
Investigating
A third party provider is currently experiencing an outage which is affecting Sauce Labs Billing services. We are monitoring the situation and will update as soon as the outage is resolved.
Posted Jan 11, 2022 - 21:09 UTC
This incident affected: Billing (US-West, EU-Central).