Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-May-29 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday May 29 2024, 15:50 - 20:00 UTC

What happened:

Tests leveraging Sauce Connect 5 Tunnels created during the time of the incident failed.

Why it happened:

A change was released to introduce new functionality that unintentionally prevented newly-created Sauce Connect 5 Tunnels from passing traffic.

How we fixed it:

The deployment was reverted and Sauce Connect 5 Tunnels created during the time of the incident were shut down.

What we are doing to prevent it from happening again:

We’re investing in additional validation checks for Sauce Connect 5.

Posted Jun 25, 2024 - 03:44 UTC

Resolved
Between 1550 and 2330 UTC, some customers running tests with Sauce Connect 5 tunnels that were created between 1550 and 2100 UTC may have experienced test failures in the US-West-1 and EU-Central-1 Data Centers. The error in the tests would be reported as "Infrastructure Error -- The Sauce VMs failed to start the browser or device". The issue is now resolved. All services are fully operational.
Posted May 29, 2024 - 16:00 UTC