Sauce Labs Maintenance Windows for Sauce Labs
The APAC-Southeast-1 REST API and app.apac-southeast-1.saucelabs.com UI are returning errors and not usable at the moment. We are taking remedial action
2022-August-16 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday August 16th 2022, 10:07 - 16:04 UTC

What happened:

A small percentage (< 1%) of users trying to load the test results dashboard in the web UI received an error message and the dashboard was unresponsive. 

Why it happened:

The API gateway we use to serve our user authentication services was experiencing intermittent issues that caused calls into those services to fail. 

How we fixed it:

We redeployed the pods for the authentication services and then eventually restarted the API gateway which restored service. 

What we are doing to prevent it from happening again:

We have added additional monitoring that will detect this specific error condition in the future. We are also expanding error rate alerting across our system and our API Gateway has been a focus of that effort.

Posted Sep 19, 2022 - 14:38 UTC

Resolved
After taking remedial action, the intermittent errors seen when accessing the Sauce Labs platform UI have been resolved. All services are fully operational.
Posted Aug 16, 2022 - 16:31 UTC
Update
We are still seeing intermittent errors when accessing the Sauce Labs platform UI on the US-West-1 Data Center. We continue to investigate.
Posted Aug 16, 2022 - 15:56 UTC
Investigating
We are seeing intermittent errors when accessing the Sauce Labs platform UI on the US-West-1 Data Center. We are investigating.
Posted Aug 16, 2022 - 15:24 UTC
This incident affected: Sauce Labs UI (US-West).