Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2023-Aug-21 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Monday August 21st 2023, 07:50 - 08:17 UTC

What happened:

Customers experienced intermittent issues loading various components in the Sauce Labs web application.

Why it happened:

Some transient failures between our public cloud providers resulted in timeouts between components, leading to errors in the Sauce Labs web application. 

How we fixed it:

The transient failures went away on their own. 

What we are doing to prevent it from happening again:

No specific actions are being taken to prevent this in the future other than our continual focus on improving the resiliency of our architecture.

Posted Sep 12, 2023 - 12:27 UTC

Resolved
We have identified the root cause, and the Sauce Labs Dashboard is now loading successfully in all our Data Centers. All services are fully operational.
Posted Aug 21, 2023 - 09:37 UTC
Monitoring
The Sauce Labs Dashboard is now loading successfully in all our Data Centers. We are monitoring.
Posted Aug 21, 2023 - 09:14 UTC
Investigating
The Sauce Labs Dashboard is intermittently failing to load in all our Data Centers. We are investigating.
Posted Aug 21, 2023 - 08:16 UTC
This incident affected: Sauce Labs Dashboard (US-West, EU-Central).