Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-May-19 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday, May 19 2021, 16:00 - 18:23 UTC 

What happened:

The Sauce Labs Platform Configurator was not available for users.

Why it happened:

Configuration changes made some of the assets used by Platform Configurator inaccessible from our Wiki page.  

How we fixed it:

We relocated the assets to an alternative location and verified Platform Configurator was available again.

What we are doing to prevent it from happening again:

We are adding new synthetics to receive early alerts if Platform Configurator experiences problems.

Posted May 25, 2021 - 09:47 UTC

Resolved
After taking remedial action, Platform Configurator is back to normal and fully operational.
Posted May 19, 2021 - 18:23 UTC
Investigating
The Sauce Labs Platform Configurator is currently not functional We are actively working on restoring this to full functionality.
Posted May 19, 2021 - 17:22 UTC
This incident affected: Sauce Labs Documentation.