Sauce Labs Partially Degraded Service
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2022-August-8 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Monday August 8th 2022, 08:30 - 09:22 UTC

What happened:

Users were unable to access the TestFairy dashboard in our web frontend. 

Why it happened:

The TestFairy dashboard relies on a datastore service that was experiencing an issue parsing data that was being written to it. Requests to the service during this time were not successful which rendered the dashboard unusable. 

How we fixed it:

We cleared the bad input and the service resumed processing the queued requests. 

What we are doing to prevent it from happening again:

We are putting in a process to ensure input to the datastore service is properly formatted.

Posted Aug 22, 2022 - 11:45 UTC

Resolved

After taking remedial action access to our TestFairy/Mobile Beta Testing platform UI has been restored.
Posted Aug 08, 2022 - 09:26 UTC

Investigating

Our TestFairy/Mobile Beta Testing platform UI is currently down. We are investigating.
Posted Aug 08, 2022 - 09:22 UTC
This incident affected: Mobile App Distribution (Mobile App Distribution UI).