Sauce Labs Maintenance Windows for Sauce Labs
We are investigating an issue with a third-party provider that is causing intermittent "Connection timed out", "pool communication" and "Unknown error while proxying appium request" errors when running tests in our EU and US datacenters. We will be performing emergency maintenance to our EU-Central and US-West datacenters this week to address this issue. Emergency maintenance windows will be posted to this page.
2024-January-25 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday January 25th 2024, 16:59 - 18:45 UTC

What happened:

New user registration was unavailable during the incident timeline.

Why it happened:

The API limit for registering a new user was triggered, which prevented new users from being able to sign up for services. 

How we fixed it:

The API limit was increased, which resolved the incident.

What we are doing to prevent it from happening again:

We are improving the monitoring and alerting of the impacted API.

Posted Jan 30, 2024 - 16:26 UTC

Resolved
We have identified and resolved the issue. All services are fully operational.
Posted Jan 25, 2024 - 21:15 UTC
Monitoring
We have fixed the root cause and currently monitoring
Posted Jan 25, 2024 - 19:14 UTC
Investigating
Users in Europe signing up for new account might experience failures. We are investigating.
Posted Jan 25, 2024 - 17:31 UTC
This incident affected: Sauce Labs Dashboard (EU-Central).