Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2025-December-18 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Thursday, December 18th 2025, 5:32 UTC - 7:09 UTC.

What happened:

The App Storage Service experienced high response times in the US-West-1 datacenter.

Why it happened:

Due to a high number of concurrent uploads, the App Storage Service experienced increased connection latency and delays in acquiring connections to the backend.

How we fixed it:

The service was restored by restarting the application.

What we are doing to prevent it from happening again:

We are implementing improved monitoring, alerting and validations for App Storage Service backend connectivity.

We will also look to enhance processes to handle periods of increased load and detect performance degradation proactively, in order to implement automated remediation and self-healing capabilities.

Posted Feb 20, 2026 - 10:20 UTC

Resolved

Between 5:40 UTC and 7:20 UTC, we experienced a high job error rate of all tests (Manual and Automated, Real Devices and Virtual Devices) in the US-West-1 data center. This issue has been resolved. All services are fully operational.
Posted Dec 18, 2025 - 05:30 UTC