Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2022-November-11 Service Incident

Incident Report for Sauce Labs

Postmortem

Posted Dec 22, 2022 - 15:08 UTC

Resolved

After taking remedial action we see all REST services functioning as expected. All services are fully operational.
Posted Nov 11, 2022 - 15:11 UTC

Monitoring

After taking remedial action, we see all REST services operating normally. We are currently monitoring
Posted Nov 11, 2022 - 14:29 UTC

Update

We continue to investigate intermittent 504 errors affecting our REST services in our EU, US and APAC data centers. This affects our UI, Sauce Connect and other REST-based products.
Posted Nov 11, 2022 - 13:54 UTC

Investigating

We are seeing intermittent 504 errors on several of our REST services in our EU, US and APAC data centers. This affects our UI, Sauce Connect and other REST-based products. We are investigating.
Posted Nov 11, 2022 - 12:35 UTC
This incident affected: Sauce Connect (US-West, EU-Central), Sauce Labs REST API (US-West, EU-Central), and Sauce Labs Dashboard (US-West, EU-Central).