We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.
After taking remedial action, access to the US-EAST data center is fully restored. This incident is resolved.
Posted Jun 01, 2026 - 18:24 UTC
Monitoring
Access has been restored to the US-EAST data center. We are monitoring.
Posted Jun 01, 2026 - 16:02 UTC
Update
We have identified the root cause and are working on implementing a fix.
Posted Jun 01, 2026 - 15:30 UTC
Update
We are continuing to investigate this issue.
Posted Jun 01, 2026 - 14:55 UTC
Investigating
We are experiencing an issue where the US-EAST data center is currently unavailable. We are investigating.
Posted Jun 01, 2026 - 14:02 UTC
This incident affected: Automated Real Device Testing (US-East), Live Real Device Testing (US-East), Native Framework Mobile App Testing (US-East), Insights (US-East), Sauce Connect (US-East), Sauce Labs REST API (US-East), and Sauce Labs Dashboard (US-East).