Sauce Labs Partially Degraded Service
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2025-February-21 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Saturday February 22nd  2025, 00:00 - 04:46 UTC

What happened:

Customers were unable to create SauceConnect tunnels in our US-West-1 and EU-Central-1 regions.

Why it happened:

The SSL certificate for the Sauce Connect frontend had expired.

How we fixed it:

The certificate was renewed and deployed to the affected regions.

What we are doing to prevent it from happening again:

We are improving our alerting around SSL certificate expiration.

Posted May 17, 2025 - 10:56 UTC

Resolved

All services are now operating as normal. This incident is resolved.
Posted Feb 22, 2025 - 05:20 UTC

Identified

We have identified the issue and have taken a remedial action. We are monitoring.
Posted Feb 22, 2025 - 02:25 UTC

Update

We are continuing to investigate this issue.
Posted Feb 22, 2025 - 01:34 UTC

Investigating

New Sauce Connect Tunnels are not able to be created on our US-West-1 & EU-Central-1 Datacenters. We are investigating.
Posted Feb 22, 2025 - 01:33 UTC
This incident affected: Sauce Connect (US-West, EU-Central).