Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2023-May-10 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday May 10th 2023, 13:35 - 14:47 UTC

What happened:

Outgoing emails like verification emails, password resets, user invitations, API Testing failure and success emails and usage notifications were not delivered during the duration of the incident. 

Why it happened:

We use a third-party service to send emails and experienced a licensing issue causing emails not to go out.

How we fixed it:

Once we addressed the licensing issue, all queued emails were sent to their recipients. 

What we are doing to prevent it from happening again:

We assigned a new business owner to ensure continued service from this third-party.

Posted Jun 02, 2023 - 17:56 UTC

Resolved

The issue with outgoing emails has been resolved and queued up emails are now being processed. This incident is resolved.
Posted May 10, 2023 - 14:53 UTC

Investigating

Outgoing emails (including account email verification, password resets, API testing failure and success emails, account invitations) are currently not sending. We are investigating.
Posted May 10, 2023 - 14:34 UTC
This incident affected: API Testing (US-West, EU-Central) and Sauce Labs Dashboard (US-West, EU-Central).