Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2022-August-4 Service Incident 2

Incident Report for Sauce Labs

Postmortem

Dates:

Thursday August 4th 2022, 10:00 - 12:25 UTC

What happened:

A partial network outage within our infrastructure caused a number of physical devices to become unavailable for a period of time. 

Why it happened:

A network switch within Sauce Labs’ data center went offline causing a portion of our physical devices to become unreachable. This marked them unavailable for automated and manual testing within the Sauce Labs’ platform. 

How we fixed it:

We power cycled the impacted switch and the affected devices became available. 

What we are doing to prevent it from happening again:

We are looking into ways we can add redundancy so that similar events are not as impactful in the future.

Posted Aug 16, 2022 - 17:03 UTC

Resolved

The Android real devices in US-West-1 are back online and available for testing.
Posted Aug 04, 2022 - 14:02 UTC

Monitoring

Android devices in our US-West-1 datacenter are now recovering. We will continue to monitor the recovery.
Posted Aug 04, 2022 - 12:46 UTC

Investigating

In our US-West-1 data center, a limited number of Android devices are currently available. We are investigating.
Posted Aug 04, 2022 - 10:59 UTC
This incident affected: Automated Real Device Testing (US-West), Live Real Device Testing (US-West), and Native Framework Mobile App Testing (US-West).