We are currently aware of an ongoing issue impacting the Talkback functionality on our Real Device Cloud. Our team is actively working to resolve this as quickly as possible.
Get email notifications whenever Sauce Labs creates, updates or resolves an incident.
Get text message notifications whenever Sauce Labs creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 20, 2024 - 06:30 UTC
Scheduled
Sauce Labs will have a two hour additional maintenance window on March 20th, starting at 06:30 UTC and ending at 08:30 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our EU and US-East data centers. These maintenance actions may cause portions of the service (including running automated and manual tests) relating to iOS real devices to be unavailable for up to two hours.
Posted Mar 18, 2024 - 10:42 UTC
This scheduled maintenance affected: Automated Real Device Testing (EU-Central, US-East) and Live Real Device Testing (EU-Central, US-East).