Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-April-30 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday April 30 2024, 14:40 - 15:05 UTC

What happened:

New tests in the Virtual Device Cloud would not start. 

Why it happened:

A change for one service caused an unhandled exception in an upstream service.

How we fixed it:

We rolled back the change introduced in a recent deployment.

What we are doing to prevent it from happening again:

We are reviewing and improving our processes for introducing changes that may affect dependent services.

Posted Jun 25, 2024 - 03:54 UTC

Resolved
Between 14:40 and 15:05 UTC, we were seeing elevated errors rates when starting Desktop and Virtual device tests in the EU-Central-1 and US-West-1 data centers. The issue is now resolved. All services are fully operational.
Posted Apr 30, 2024 - 15:00 UTC