Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2023-October-26 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday October 26th 2023, 17:03 - 17:30 UTC

What happened:

For the duration of the incident, customers could not upload new files or list files/groups through the Web UI. Some users received an HTTP error code of 429 due to them being rate-limited. 

Why it happened:

Customers began to have issues uploading assets to our storage service due to a high number of concurrent uploads. This spike in upload requests caused a delay in acquiring a backend connection for the storage service. 

How we fixed it:

We recycled the storage service pods, which cleared the connectivity issue with our backend service. 

What we are doing to prevent it from happening again:

We are looking at the following areas:

  • Determining how better to handle periods of increased load for our storage service.
  • Refining our alerting for our storage service to detect performance issues customers may experience when interacting with it.
Posted Nov 28, 2023 - 10:15 UTC

Resolved
Live and Automated tests on Real Devices/Emulators/Simulators have remained stable on our US-West Data Center. All services are fully operational.
Posted Oct 26, 2023 - 21:45 UTC
Monitoring
Real device and Emulator/Simulator tests are running successfully in our US West data center. We continue to monitor.
Posted Oct 26, 2023 - 18:08 UTC
Investigating
We are aware of an ongoing issue related to Application Management impacting RDC and Emulator/Simulator Live and Automated tests on our US-West Data Center. We're investigating
Posted Oct 26, 2023 - 17:42 UTC
This incident affected: Automated Virtual Mobile Device Testing (US-West), Automated Real Device Testing (US-West), Live Virtual Mobile Device Testing (US-West), Live Real Device Testing (US-West), API Testing (US-West), and Native Framework Mobile App Testing (US-West).