Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2025-October-29 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Monday, October 27th 2025, 15:27 UTC - Wednesday, October 29th 2025, 11:34 UTC.

What happened:

Real Device Live Testing availability gradually decreased in the US-West-1 data center.

Why it happened:

A product defect was introduced which caused Live Testing sessions on Real Devices to fail to start.

How we fixed it:

We performed a rollback to the previous working release.

What we are doing to prevent it from happening again:

We have improved monitoring & alerting and enhanced our post-deployment validation processes.

Posted Dec 11, 2025 - 17:01 UTC

Resolved

After taking remedial action, live tests on Real Devices are now running normally in the US-West-1 Data Center. All services are fully operational.
Posted Oct 29, 2025 - 10:47 UTC

Investigating

We are currently experiencing issues with live test execution on Real Devices for IOS and Android in the US-West-1 datacenter. We are investigating.
Posted Oct 29, 2025 - 09:27 UTC
This incident affected: Live Real Device Testing (US-West).