Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-February-27 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Saturday February 24th 2023, 01:00 UTC to Wednesday February 28th 2023, 23:14 UTC

What happened:

Increased network load which led to intermittent test slowness or failures.

Why it happened:

An update was automatically triggered when a customer test was executed which led to increased network load.

How we fixed it:

Deployed new images for impacted operating systems.

What we are doing to prevent it from happening again:

Ensure new images do not auto update and improve alerting on this condition.

Posted Mar 07, 2024 - 10:00 UTC

Resolved
Real device availability and error rates for automated and live browser and virtual mobile device tests are within the normal levels in the US-West-1 data center.
Posted Feb 28, 2024 - 06:08 UTC
Investigating
We are seeing elevated error rates for automated and live browser and virtual mobile device tests and intermittently unavailable real devices in our US-West datacenter. We are investigating.
Posted Feb 28, 2024 - 03:52 UTC
This incident affected: Automated Browser Testing (US-West), Automated Virtual Mobile Device Testing (US-West), Automated Real Device Testing (US-West), Live Browser Testing (US-West), Live Virtual Mobile Device Testing (US-West), Live Real Device Testing (US-West), and Sauce Labs REST API (US-West).