Sauce Labs Partially Degraded Service
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2025-May-14 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday May 14th 2025, 08:00 UTC - 09:03 UTC

What happened:

An authentication failure lead to Real Device live & automated app tests our in US-East-4 Datacenter.

Why it happened:

Connections from the App Storage service failed due to a database issue.

How we fixed it:

The database cluster required restarting.

What we are doing to prevent it from happening again:

Database clean-ups will be done only during maintenance windows.

Posted Jun 13, 2025 - 10:43 UTC

Resolved

After taking remedial action, app uploads and testing are now both working correctly. This incident is resolved
Posted May 14, 2025 - 09:40 UTC

Investigating

We are currently seeing errors in uploading and installing apps in our US-East-4 Datacenter. We are investigating.
Posted May 14, 2025 - 09:10 UTC
This incident affected: Automated Real Device Testing (US-East), Live Real Device Testing (US-East), and Native Framework Mobile App Testing (US-East).