Sauce Labs Partially Degraded Service
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2025-May-6 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Tuesday April 6th 2025, 03:38 UTC - 03:58 UTC

What happened:

RDC devices were unavailable in the EU-Central-1 Datacenter.

Why it happened:

There was a DNS caching failure during a third party provider’s maintenance.

How we fixed it:

Availability was restored automatically, after the instances completed their start-up.

What we are doing to prevent it from happening again:

We will update our DNS caching for better fault tolerance.

Posted May 17, 2025 - 10:53 UTC

Resolved

Between 03:38 - 03:58 UTC, Real Devices in our EU data center were unavailable. After taking remedial action, the issue has been resolved. All services are fully operational.
Posted May 06, 2025 - 02:30 UTC