Sauce Labs Maintenance Windows for Sauce Labs
We are seeing issues running automated tests in our Apac-Southeast-1 Data Center, we are currently investigating.

2022-June-08 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

June 8th 2022, 12:20 - 12:58 UTC

What happened:

Virtual device test results were not available on the Sauce Labs dashboard for our EU-Central-1 data center.

Why it happened:

A SQL query with inefficient parameters was executed and caused api service to wait for its response, which took a long time to finish. This caused a build up of waiting requests and timeouts were hit waiting for responses.

How we fixed it:

We canceled the long running query unblocking all other requests. 

What we are doing to prevent it from happening again:

We have optimized the query.

Posted Jun 15, 2022 - 15:51 UTC

Resolved
Test results are now being displayed correctly. This incident is resolved.
Posted Jun 08, 2022 - 13:00 UTC
Investigating
Virtual Device test results are not loading in the dashboard for our EU-Central-1 data center. We are investigating.
Posted Jun 08, 2022 - 12:51 UTC
This incident affected: Sauce Labs UI (EU-Central).