Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-Mar-25 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Monday March 25th 2024, 14:47 - 14:59 UTC

What happened:

Automated and live tests for virtual and real device clouds in the US West region failed.

Why it happened:

An invalid configuration was deployed that prevented connections from being accepted.

How we fixed it:

We rolled back the configuration to the previous version.

What we are doing to prevent it from happening again:

The underlying cause for the misconfiguration of the service, a template logic error, was fixed.

Posted Apr 09, 2024 - 14:23 UTC

Resolved
Between 14:48 - 14:58 UTC, a configuration change on our side resulted in test failures reaching ondemand.us-west-1.saucelabs.com. We have identified the issue and taken remedial action.
Posted Mar 25, 2024 - 16:06 UTC