Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-May-19 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday May 19th 2022, 01:50 - 3:10 UTC

What happened:

Our Real Device Cloud in the EU was not available to start any new tests for automated and manual tests. No devices were visible and accessible for running tests.

Why it happened:

A bad change to the database collection that includes the configuration for real mobile devices was conducted. Our services received an error when they were trying to read the collection to get information about which devices were connected to the real device cloud in Europe.

Change to the device configuration of a single device was done directly in the database. 

The tool that was used to change the database was faulty. Necessary diligence and checks to prevent a change like that to be allowed to happen were not in place.

How we fixed it:

The faulty document was removed. 

What we are doing to prevent it from happening again:

We are limiting access to the database further, and adding additional checks. 

We will also improve our internal tooling that allows us to do changes to device configurations in a safer way.We are adding additional alerts that trigger an immediate response for similar scenarios.

Posted May 31, 2022 - 17:08 UTC

Resolved
Between 2:50 UTC and 4:00 UTC all real devices in our EU-Central-1 data center were temporarily unavailable. We took remedial action and the problem was resolved. All services are fully operational.
Posted May 19, 2022 - 03:00 UTC