Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-May-2 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday May 2 2024, 09:30 - 11:00 UTC

What happened:

There was reduced availability of Real devices for customers. 

Why it happened:

An internal API change resulted in devices being incorrectly marked as unavailable.

How we fixed it:

We rolled back the change introduced in a recent deployment.

What we are doing to prevent it from happening again:

We are updating the dependency to improve error handling.

Posted May 23, 2024 - 10:06 UTC

Resolved
Between 9:30 AM and 11:00 AM UTC, we were experiencing decreasing availability of Real Devices in all data centers. This has now been resolved and device availability is at normal levels.
Posted May 02, 2024 - 11:00 UTC