Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-August-03 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday August 3rd 2022, 05:10 - 08:17 UTC

What happened:

Customers in our US-EAST-1 region were unable to start new test sessions.

Why it happened:

The process that is responsible for allocating resources to test requests had an abnormal amount of instances running, most of which were not functioning properly. The scheduling services that manages these instances wasn’t cleaning these particular instances correctly. As customers were attempting to start new sessions they were being attached to these instances which prevented the session from starting cleanly.  

How we fixed it:

We manually cleaned up the instances that were not functioning properly. 

What we are doing to prevent it from happening again:

We are addressing the issue in the scheduling service to better detect and clean up instances that aren’t healthy.

Posted Aug 16, 2022 - 16:59 UTC

Resolved
This incident has been resolved.
Posted Aug 03, 2022 - 08:42 UTC
Identified
We have identified the issue and taken corrective action. Headless tests are now running, but we are still working to bring the issue to full resolution.
Posted Aug 03, 2022 - 08:11 UTC
Investigating
Automated tests are failing to start in our US-East-1 Headless data center. We are investigating.
Posted Aug 03, 2022 - 06:07 UTC