Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2024-June-14 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday June 14th 2024, 10:30 - 19:20 UTC

What happened:

Customers may have received intermittent 503 errors when running tests.

Why it happened:

A required network component on a node crashed during automated restarts and did not automatically recover.

How we fixed it:

We recovered the impacted node, which allowed the network component to start correctly.

What we are doing to prevent it from happening again:

We have improved the alerting for the network component to ensure automated upgrades and restarts complete correctly.

Posted Aug 10, 2024 - 13:18 UTC

Resolved

After taking remedial action, all services are operating as normal. This incident is resolved.
Posted Jun 14, 2024 - 19:27 UTC

Investigating

We are currently seeing intermittent issues when running automated tests in our US West Data center. Users would encounter the "503 Service Unavailable" error on their end. We are investigating.
Posted Jun 14, 2024 - 18:45 UTC
This incident affected: Automated Browser Testing (US-West), Automated Virtual Mobile Device Testing (US-West), Automated Real Device Testing (US-West, US-East), and Native Framework Mobile App Testing (US-West).