We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day
Get email notifications whenever Sauce Labs creates, updates or resolves an incident.
Get text message notifications whenever Sauce Labs creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Our Android devices are now fully operational in EU-Central Data Center. We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center, which is leading to degraded availability for our iOS user base. We have identified the root cause and implementing a final fix. We expect to restore full availability for all iOS users by tomorrow, Thursday, July 3, 2025, end of day
Posted Jul 02, 2025 - 20:11 UTC
Update
We are actively working on a solution to resolve the networking issues being seen in the EU datacenter, which involves replacing failed hardware. A high error rate will continue to be seen with EU Real Device tests in the meantime.
Posted Jul 02, 2025 - 16:19 UTC
Update
We have identified a networking issue in the EU-Central-1 datacenter, resulting in a high error rate in EU Real Device tests. We are continuing to investigate.
Posted Jul 02, 2025 - 11:50 UTC
Update
We are continuing to see reduced availability of Real Devices in our EU-Central-1 datacenter. We are continuing to investigate.
Posted Jul 02, 2025 - 11:12 UTC
Investigating
We are currently experiencing reduced availability of Real Devices in our EU-Central-1 datacenter. We are investigating.
Posted Jul 02, 2025 - 10:11 UTC
This incident affected: Automated Real Device Testing (EU-Central), Live Real Device Testing (EU-Central), and Native Framework Mobile App Testing (EU-Central).