Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-March-18 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday, March 18, 2021 16:48 UTC - 18:08 UTC

What happened:

RDC automated tests failed to upload assets to our EU and US data centers, causing the test reports on the Sauce Labs UI to be displayed as in-progress indefinitely.

Why it happened:

During the course of normal security related work involving policy and group updates, certain permissions related to Amazon S3 access were changed for one of our service accounts, which was incorrectly placed in one of the groups. This prevented the service from uploading assets to AWS.

How we fixed it:

The service account was added to a group that allows read/write access to S3.

What are we doing to prevent it from happening again:

We will create new service accounts in the proper groups and implement the necessary policy changes to ensure the correct access rights are in place.

Posted Mar 24, 2021 - 11:12 UTC

Resolved
After taking remedial action, all assets are uploaded successfully. All services fully operational.
Posted Mar 18, 2021 - 18:11 UTC
Investigating
RDC automated tests fail to upload assets on our EU and US datacenter. We are investigating.
Posted Mar 18, 2021 - 17:56 UTC
This incident affected: Automated Real Device Testing (US-West, EU-Central).