Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-May-18 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday May 18 2021, 12:21 - 16:29 UTC

What happened:

Users were unable to create new accounts in our US-West-1 data center.

Why it happened:

One of our database nodes became overloaded due to a prior data migration. Some services were not able to connect to the database due to timeouts.

How we fixed it:

We performed a failover to another healthy database node.

What we are doing to prevent it from happening again:

We are improving observability & monitoring of critical paths in our system like user registration so that we can react more quickly.

Posted May 20, 2021 - 17:25 UTC

Resolved
We have taken remedial action and accounts are now created successfully. All services are fully operational.
Posted May 18, 2021 - 16:58 UTC
Investigating
We have received reports of not being able to create accounts on sign up and for existing organizations on our us-west-1 datacenter. We are investigating.
Posted May 18, 2021 - 16:14 UTC
This incident affected: Sauce Labs UI (US-West).