Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-June-1 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday June 1st 2022, 18:51 - 21:03 UTC

What happened:

Sauce Connect tunnels failed to start in our US-East-1 data center.

Why it happened:

We removed a deprecated resource, but there was a lingering dependency on it which impacted our tunnel functionality. 

How we fixed it:

We redeployed the resource and ensured that network traffic was operating as normal. 

What we are doing to prevent it from happening again:

We are working on improving the dependency mapping we use to perform these types of maintenance tasks.

Posted Jun 14, 2022 - 09:58 UTC

Resolved
After taking remedial action we are seeing tunnels start back up as expected in our us-east-1 data center. Long running tunnels may need to be restarted. All services are fully operational.
Posted Jun 01, 2022 - 21:10 UTC
Update
Tunnels are still not able to be created or used in our us-east-1 data center. We continue to take remedial action to bring our tunnel service back.
Posted Jun 01, 2022 - 20:38 UTC
Investigating
We are seeing all tunnels not working properly in our us-east-1 data center. We are investigating.
Posted Jun 01, 2022 - 19:52 UTC