Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-July-2 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday, July 2, 10:54 - 15:57 UTC

What happened?

Some customers received erroneous messages stating they were running at their maximum concurrency, preventing them from starting new tests.

Why did it happen?

During a routine deployment, a serialization library was updated. The update contained a dependency with a non-compatible, breaking change that made the read/write values of this service to not work.

How was it resolved?

The deployment was rolled back.

What are we doing to prevent it from happening again?

We have deployed an upgrade which removed the dependency on the library that caused this issue. We will also be improving our post release external monitoring system to monitor the API endpoint that was affected by this issue.

Posted Jul 13, 2021 - 18:03 UTC

Resolved
We have taken remedial action. CCY endpoints and tests now should run as expected. All services are fully operational.
Posted Jul 02, 2021 - 15:57 UTC
Investigating
We are getting reports on incorrect CCY usage on our UI. This may cause tests to fail incorrectly due to too many VMs running. We are investigating.
Posted Jul 02, 2021 - 15:25 UTC
This incident affected: Live Virtual Mobile Device Testing (US-West, EU-Central), Automated Virtual Mobile Device Testing (US-West, EU-Central), Automated Browser Testing (US-West, US-East (Headless), EU-Central), Sauce Labs REST API (US-West, US-East (Headless), EU-Central), and Live Browser Testing (US-West, EU-Central).