Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-July-8 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

‌07/08/2024 18:21 UTC to 07/08/2024 19:13 UTC

What happened:

Many pages of our website were unreachable or prohibitively slow. Potential customers couldn’t visit our website and existing customers who use our site as a login area may have been hindered.

.

Why it happened:

Our CMS provider, Contentful, was experiencing an outage which meant that we couldn’t generate pages.

How we fixed it:

Contentful resolved the outage.

What we are doing to prevent it from happening again:

We are switching our website from on-demand rendering to build-time rendering, this means the pages are built at runtime and served from a CDN, so no need for real-time rendering.

Posted Aug 15, 2024 - 08:30 UTC

Resolved
After taking remedial action all services are operating as normal. This incident is resolved.
Posted Jul 08, 2024 - 19:35 UTC
Investigating
We are currently seeing saucelabs.com website pages loading slow and throwing errors. We are investigating.
Posted Jul 08, 2024 - 19:06 UTC
This incident affected: Other (saucelabs.com).