Sauce Labs Maintenance Window
We are aware of an ongoing issue preventing logins to App Distribution when using Single Sign-On (SSO). We are actively investigating..

2025-October-28 Resolved Service Incident 1

Incident Report for Sauce Labs

Postmortem

Dates:

Thursday, October 9th 2025, 10:28 UTC - Tuesday, November 11th 2025, 11:34 UTC.

What happened:

Virtual Android testing availability gradually decreased in the US-West-1 data center, this led to increased error rates in starting sessions, The error rates remained high between November 4th and November 11th.

Why it happened:

An increased and sustained load on our service led to reduced availability of Android virtual VMs, increasing wait times to start sessions, which in turn led to an elevated number of failed sessions.

How we fixed it:

This was resolved by increasing infrastructure capacity and optimizing resource utilization.

What we are doing to prevent it from happening again:

We have improved monitoring & alerting, enhanced post-deployment validation and improved capacity planning.

Posted Dec 11, 2025 - 16:41 UTC

Resolved

Between 11:20 UTC and 12:10 UTC, we experienced a high error rate of virtual Android tests in the US-West-1 data center. This issue has been resolved. All services are fully operational.
Posted Oct 28, 2025 - 11:30 UTC