Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2025-May-14 Service Incident 1

Incident Report for Sauce Labs

Postmortem

Dates:

Thursday May 13th 2025, 10:26 UTC - Friday May 14th 2025 16:48 UTC

What happened:

Video recordings for Android tests intermittently failed in the US-West-1 datacenter.

Why it happened:

A service involved in capturing recordings entered a deadlocked state when receiving a specific combination of requests and options.

How we fixed it:

We cleared the deadlocked service.

What we are doing to prevent it from happening again:

We are introducing additional monitors and automatic recovery for the deadlocked condition.

Posted Jun 13, 2025 - 10:45 UTC

Resolved

We have identified the root cause and deployed a fix for this issue. This incident is resolved.
Posted May 14, 2025 - 17:16 UTC

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 17:16 UTC

Investigating

We are currently investigating an issue where video recordings for Android tests are intermittently missing in our US West Datacenter. The issue began on May 13th at approximately 13:00 CEST.
Posted May 14, 2025 - 16:49 UTC
This incident affected: Automated Real Device Testing (US-West) and Live Real Device Testing (US-West).