Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-February-19 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Monday February 19th 2024, 17:30 UTC - Monday February 19th, 23:06 UTC

What happened:

Real Devices in our US-West-1 data center running iOS 17 were degraded and may intermittently have disconnected a user. Additionally, at times, iOS 17 Real Devices may have been unavailable for use.

Why it happened:

Real Devices running iOS 17 experienced an unknown gradual degradation over time.

How we fixed it:

Real Devices running iOS 17 were restarted.

What we are doing to prevent it from happening again:

We are working to improve our observability of iOS 17 and improving iOS 17-specific design elements for Real Devices.

Posted Mar 12, 2024 - 11:38 UTC

Resolved
After taking remedial action, iOS 17 Real devices are available in US-West-1 data center. All services are fully operational.
Posted Feb 19, 2024 - 22:12 UTC
Identified
We have identified the cause and taking remedial action.
Posted Feb 19, 2024 - 21:51 UTC
Investigating
iOS 17 Real devices are currently unavailable in the US-West-1 data center. We are investigating.
Posted Feb 19, 2024 - 21:20 UTC
This incident affected: Automated Real Device Testing (US-West), Live Real Device Testing (US-West), and Native Framework Mobile App Testing (US-West).